Live Forms v6.1 is no longer supported. Click here for information about upgrading to our latest GA Release.

Skip to end of metadata
Go to start of metadata

Forms/flows created on Live Forms v5.2 patch 1+ or v5.3+ will not require further attention post migration. However, there are a few migration items that you need to consider. Please read and understand the Planning for v6.1 which may require your action before you begin your upgrade. 

 Please follow the instructions on this page, to perform your upgrade. Click on the link for the section that applies.

 

Migrating from HSQLDB

Live Forms does not support the use of HSQLDB for use beyond demo/trials of the Live Forms software. If by mistake you continued to use the demo/trial HSQLDB database for production use, you will need to first migrate your data to one of Live Forms supported production databases BEFORE you can use the automated migration scripts to upgrade to later versions of Live Forms.

Upgrading from v4.x - 4.1.6

You will need to upgrade to version 4.1.7 before migrating to Live Forms version 5 and then to version 6. Refer to Upgrading Your In House Server to v4.1.7 for the details. When the upgrade to v4.1.7 is complete, return to this page and continue with the Upgrading from v4.1.7+  section below:

Upgrading from v4.1.7+

You will need to upgrade to version 5.3 before migrating to Live Forms version 6. Refer to Upgrading from v4.1.7+ in the v5.3 documentation for the details. When the upgrade to  v5.3 is complete, return to this page and continue with the Upgrading from v5.2 patch1+ or v5.3+ section below.

Upgrading from v5.1.x

You will need to upgrade to version 5.3 before migrating to Live Forms version 6. Refer to Upgrading from v5.1.x in the v5.3 documentation for the details. When the upgrade to  v5.3 is complete, return to this page and continue with the Upgrading from v5.2 patch1+ or v5.3+ section below.

 

Upgrading from v5.2 patch 1+ or v5.3+

Your Live Forms server must be running v5.2.1 patch 1+ or v5.3+ before proceeding with the following steps

Please read the following upgrade steps prior to starting the migration.

  1. Please read and understand the Migration Considerations which may require your action before beginning.
  2. Backup the v5 server's forms and users databases.
  3. Backup the v5 server's installation directory so that you have a copy of all custom configuration parameters.
  4. Stop the v5 server using stop-frevvo.[bat,sh] or through the Computer Management Services console if Live Forms is running as a window's service.
  5. Install a fresh v6 Live Forms server:
    1. Download the latest v6.1 software.
    2. The download is a zip file. Extract the contents to any folder of your choice. This folder will be referred to as <frevvo-home> (note that the zip already contains a top level frevvo folder). 
  6. The execution of SQL scripts is no longer required. All database initialization and/or upgrade will be done by frevvo.war as part of the Live Forms v6.1 startup. 
     

    The users schema for the version you are migrating from must be located on the same database server instance as the new frevvo 6 schema. The upgrade process directly selects from the old users schema and inserts into the new frevvo 6 schema using a single sql statement.

  7. If you are using the tomcat servlet, follow the steps below to configure the v6.1 <frevvo-home>\tomcat\conf\catalina\localhost\frevvo.xml file for migration.
    1. Navigate to <frevvo-home>\tomcat\conf\catalina\localhost\frevvo.xml in the v6.1 directory structure.
    2. Point v6.1 frevvo database to your v5.2 patch 1+ or v5.3+ frevvo database. An example for MySQL is shown below:

       
       

    3. For SQL server database migration:
      1. Uncomment " <Parameter name="frevvo.users.schemaName" value="users.dbo" override="false"/>" in frevvo.xml and comment out "<Parameter name="frevvo.users.schemaName" value="users" override="false"/>".  
      2. Set the value of frevvo.users.schemaName in the v6.1 frevvo.xml file to the name of the users database of the version you are migrating from.  If you didn't change the name of the users schema in the version you are migrating from, then you can leave it as the default, users. Make sure you append .dbo to the users schema name if you are using an SQL server database.
      3. Add the sendStringParametersAsUnicode property with a value of false to your database connection URL if it is not already there.

    5.3 customers using LDAP must copy their LDAP config parameters from the frevvo.xml file of the version you are migrating from to the v6.1 version frevvo.xml BEFORE starting the v6.1 server for the first time. Live Forms will then migrate the config to the tenant level on startup.  LDAP parameters can then be edited in the v6.1 UI.



  8. During the upgrade from 5.x to 6.1, Live Forms copies the data in the old users schema into the corresponding new tables in the frevvo schema.  The users and frevvo schemas are being consolidated as part of the 6.1 release.  In order to do this, Live Forms uses the frevvo database user to select the data from the old users schema.  Therefore, the frevvo database user must have select access to all of the tables in the old user.  In case your database is  not already configured for this, you must grant select permission to the frevvo user on these tables BEFORE upgrading.

     Below is an example of the queries needed to grant select permission on the users schema to the frevvo user for the Oracle database: 

    If you are using a database other than Oracle, similar statements need to be executed. Please consult your database documentation for the correct syntax. 

    The frevvo db user id requires the database level privileges listed below on first startup. If your database is not set up for this already, privileges will be needed for the following actions:  

    • Create Table
    • Alter Table
    • Drop Table
    • Create Index
    • Create Sequence (Oracle)
    • Create Trigger  

    .

  9. If you are using the JBOSS container, make the following additions to the configuration files:

    1. JBOSS container : Quartz parameter has to be added to frevvo-config.properties file. e.g in case of MSSQL database, add the following in this file:

      "org.quartz.jobStore.driverDelegateClass=org.quartz.impl.jdbcjobstore.MSSQLDelegate" 

       

    2. JBOSS + SQL server : "SelectMethod=cursor" has to be added to the connection url in frevvo-ds.xml file as follows : 

      "<connection-url>jdbc:sqlserver://localhost:1433;databaseName=frevvo;SelectMethod=cursor;</connection-url>" 

    3. The Quartz parameter is not required for starting the frevvo server if you are using WEBLOGIC. 

  10. Configure the new installation
    • If you made changes to the following files in your  v5 installation, you will need to make the same changes in the new v6 configuration files.
      • <frevvo-home>/tomcat/conf/server.xml
      • <frevvo-home>/tomcat/conf/Catalina/localhost/frevvo.xml
      • We recommend that any changes that were made to the web.xml file be moved to frevvo.xml instead
      • The three files mentioned above include: 

     11. Start the v6.1 server.

The users database, required for previous versions of Live Forms, is no longer needed. The 6.1 automigration creates a new frevvo database that contains all the tables from frevvo and users databases of the the previous version along with any new ones.

     12. Upgrade all users and their forms to v6.1. This step is VERY IMPORTANT. Follow these instructions:

    1. After you have started the v6.1 server, login as admin@d user.
    2. Browse this URL in the same browser: http://localhost:8082/frevvo/web/upgradeUsers?force=true. Replace localhost:8082 in this URL with your frevvo server host :port

Things to Check:

  • Login as a tenant admin
  • Click on the Configuration Checklist link to verify that all configurations are complete
  • Login as a tenant designer user
  • View and edit a form/flow
  • View submissions that existed before
  • Test forms/flows 

Troubleshooting:

It is recommended that you do not change or delete the frevvo.users.schemaName property in frevvo.xml after the first startup of v6.1.  If the property is changed or deleted post migration you may see this error:

Follow these steps to rectify the situation:

  1. Change the property back to what it was during migration and restart.
  2. If step 1 does not fix the problem, delete all rows from the DATABASECHANGELOG database table and then restart. Use the command: delete from DATABASECHANGELOG. 

Unexpected Error

You may see an unexpected error due to a misconfiguration. One likely cause is that you have copied an older version of frevvo.xml or web.xml from your old Live Forms server into your new Live Forms server. The upgrade will detect this error and alert you that an upgrade error may have occurred. To solve this replace frevvo.xml and/or web.xml with the version that came with your new Live Forms software. To transfer configuration customizations from your old server software to you new server, edit frevvo.xml and/or web.xml and copy the changes over manually.

Applying a Minor Patch Update

If you're applying a minor patch update, for example, applying patch 6.1.1 to your installed v6.1 Live Forms server, you can follow these simple steps instead of the more lengthy upgrade steps. 

The latest major Live Forms version and latest connector versions are available on the public Software Downloads page.

Follow these steps:

  1. Unzip the downloaded build zipfile to a temp directory. 
  2. Copy the \temp\frevvo\tomcat\webapps\frevvo.war file.

  3. Stop Live Forms.

  4. Replace the frevvo.war file in your installation with the one copied above.

  5. If you made any change in the web.xml file of your frevvo.war, then you will have to make those changes again in the web.xml file of the new frevvo.war. The steps to do this are explained here or you can just copy the old web.xml and replace the new one with it.

  6. Delete everything inside \frevvo\tomcat\temp directory of your installation.

  7. Start Live Forms

Live Forms for Confluence

If you are running Live Forms for Confluence please follow the same instructions above to upgrade your Live Forms server. If you are upgrading from Live Forms for Confluence v5.3, then this upgrade does not require an upgrade to your frevvo-Confluence Add-on. Please refer to the Confluence Add-on Release Notes compatibility matrix. The Live Forms server and the Live Forms Confluence Add-on versions must match.

If you do not find your Confluence server version in the  Confluence Add-on Release Notes compatibility matrix, please contact support at frevvo.com.

Database Connector

If you are using the Live Forms database connector, you must reinstall and configure it again for the v6.1 installation.

 

 

 

 

 

 

 

  • No labels