Live Forms v6.3 is no longer supported. Click here for information about upgrading to our latest GA Release.

Skip to end of metadata
Go to start of metadata

Why Upgrade?

Live Forms v6.3 contains new features that improve usability and makes designing forms easier. Here are a few of the top reasons to upgrade:

See the Live Forms v6.3 release notes for more reasons to upgrade.

On This Page:


The v6.3 migration is automatic, however, we do recommend that you read the information below before you begin.

Just a reminder that the IP address for http://app.frevvo.com/ is 54.86.85.105. Customers that use firewall white listing for http://app.frevvo.com/ must add this IP address to your white list . This is applicable for outgoing HTTP POSTs to connectors. For example if your forms are posting to the frevvo database connector or any other connector you installed behind your company firewall.

Automatic Upgrade for Live Forms Online (Cloud Hosted) Customers

Live Forms Online cloud hosted customers (SaaS) will be automatically upgraded on 2/13/16. The automatic cloud upgrade will be seamless. Cloud customers should quickly review the topics listed below  to prepare for the new version of Live Forms 

If you have any questions, please email support@frevvo.com

Live Forms In-house Customers

Please review the instructions in the Upgrade Guide and Supported Platforms before migrating.

It is recommended that you perform a full installation of Live Forms v6.3 when upgrading.

Live Forms v6.3 requires a minimum tomcat version of 7.0.65+. The upgraded version of tomcat includes support for Servlet API v3.0.  If you are using the Live Forms tomcat bundle, the upgraded versions are already included.

httpclient-auth properties file

In-house customers using the httpclient-auth properties for HTTP Authentication to external web services, must ensure the file is present in the frevvo.war, BEFORE you perform the first startup of v6.3. If the httpclient-auth.properties file containing credentials exists, the credentials will be copied into each existing tenant when v6.3 starts up fpr the first time immediately following an upgrade from a previous version. After this, the httpclient-auth.properties file is no longer used and any further changes to it will be ignored. This is a one time upgrade.

LDAP/Active Directory Security Manager Configuration

Live Forms in-house (on-premise) customers should be aware that the configuration of the LDAP/Active Directory Security Manager is now done using the Add/Edit Tenant user interface  LDAP configuration properties that were previously included in the frevvo.xml file can be managed via these Live Forms screens. Click here for more information on this topic.

Existing LDAP customers should refer to the  Upgrade Guide for a quick way to import your current LDAP configuration properties before migrating. You must be upgrading from v6.1+ for this to work.

Uploaded Custom JavaScript for Forms/Flows

If your custom JavaScript does not behave as expected after upgrading your version of Live Forms, it may be caused by a scrubbing of the custom.js file content by XSS protection. You may notice that all your code is on a single commented out line upon Inspection of the custom.js file,

This was fixed in the Live Forms v6.3.5 patch. Although it is always recommended to upgrade to the latest version of Live Forms, if you are upgrading to a v6.3 version that is earlier than v6.3.5, download the custom.js file BEFORE upgrading. If the version you are upgrading to, for example, v6.3.4, shows the problem, you will have to upload an "unscrubbed" version of your custom.js file to resolve the issue.


  • No labels